$re = '/(.*?)\n(.*?)/';
$str = '02.04.2024 02.04.2024 280 "ADDEBITO SEPA DD PER FATTURA A VOSTRO CARICO Incasso 2023-03-24
17 53 26.259 SDD da IT38ZZZ0000001168010070 KNOT SRL mandato nr.
BJWRS001212620072" -871,18
02.04.2024 29.03.2024 43 "PAGAMENTO VISA Contactless del 29/03/2024 CARTA *8642 DI EUR 15,12 2L
AOSTA" -15,12
03.04.2024 03.04.2024 48 "BONIFICO A VOSTRO FAVORE BONIFICO SEPA DA LA KIUVA SOCIETA
COOPERATIVA PER fattura COMM 0,00 SPESE 0,00 TRN 1001240942034482" 1.098,00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);