const regex = /(.*?)\n(.*?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)\\n(.*?)', '')
const str = `02.04.2024 02.04.2024 280 "ADDEBITO SEPA DD PER FATTURA A VOSTRO CARICO Incasso 2023-03-24
17 53 26.259 SDD da IT38ZZZ0000001168010070 KNOT SRL mandato nr.
BJWRS001212620072" -871,18
02.04.2024 29.03.2024 43 "PAGAMENTO VISA Contactless del 29/03/2024 CARTA *8642 DI EUR 15,12 2L
AOSTA" -15,12
03.04.2024 03.04.2024 48 "BONIFICO A VOSTRO FAVORE BONIFICO SEPA DA LA KIUVA SOCIETA
COOPERATIVA PER fattura COMM 0,00 SPESE 0,00 TRN 1001240942034482" 1.098,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}