import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)\\n(.*?)";
final String string = "02.04.2024 02.04.2024 280 \"ADDEBITO SEPA DD PER FATTURA A VOSTRO CARICO Incasso 2023-03-24\n"
+ "17 53 26.259 SDD da IT38ZZZ0000001168010070 KNOT SRL mandato nr.\n"
+ "BJWRS001212620072\" -871,18\n"
+ "02.04.2024 29.03.2024 43 \"PAGAMENTO VISA Contactless del 29/03/2024 CARTA *8642 DI EUR 15,12 2L\n"
+ "AOSTA\" -15,12\n"
+ "03.04.2024 03.04.2024 48 \"BONIFICO A VOSTRO FAVORE BONIFICO SEPA DA LA KIUVA SOCIETA\n"
+ "COOPERATIVA PER fattura COMM 0,00 SPESE 0,00 TRN 1001240942034482\" 1.098,00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}