#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Za-z']+\b(?=\s) \b[A-Za-z']+\b(?=,)"
Local $sString = "Mrs. Doll Sheehan,,1,,1," & @CRLF & _
"Ms. Sandy Frye,,1,1,2," & @CRLF & _
"Mr. Thorne's,,,,0,RD" & @CRLF & _
"Mr. & Mrs. Richard Bissett,1,1,,2," & @CRLF & _
"Mr. Andrew Waldron Wakefield,1,,,1," & @CRLF & _
"Mr. Darren Bissett,1,,,1," & @CRLF & _
"Mr. & Mrs. Russel Sheehan,1,,1,2," & @CRLF & _
""Christine, David, Eli, Julia Oliver",2,1,1,4," & @CRLF & _
"derose85@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")