import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Za-z']+\\b(?=\\s) \\b[A-Za-z']+\\b(?=,)";
final String string = "Mrs. Doll Sheehan,,1,,1,\n"
+ "Ms. Sandy Frye,,1,1,2,\n"
+ "Mr. Thorne's,,,,0,RD\n"
+ "Mr. & Mrs. Richard Bissett,1,1,,2,\n"
+ "Mr. Andrew Waldron Wakefield,1,,,1,\n"
+ "Mr. Darren Bissett,1,,,1,\n"
+ "Mr. & Mrs. Russel Sheehan,1,,1,2,\n"
+ "\"Christine, David, Eli, Julia Oliver\",2,1,1,4,\n"
+ "derose85@gmail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}