using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Za-z']+\b(?=\s) \b[A-Za-z']+\b(?=,)";
string input = @"Mrs. Doll Sheehan,,1,,1,
Ms. Sandy Frye,,1,1,2,
Mr. Thorne's,,,,0,RD
Mr. & Mrs. Richard Bissett,1,1,,2,
Mr. Andrew Waldron Wakefield,1,,,1,
Mr. Darren Bissett,1,,,1,
Mr. & Mrs. Russel Sheehan,1,,1,2,
""Christine, David, Eli, Julia Oliver"",2,1,1,4,
derose85@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}