const regex = /\b[A-Za-z']+\b(?=\s) \b[A-Za-z']+\b(?=,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Za-z\']+\\b(?=\\s) \\b[A-Za-z\']+\\b(?=,)', 'gm')
const str = `Mrs. Doll Sheehan,,1,,1,
Ms. Sandy Frye,,1,1,2,
Mr. Thorne's,,,,0,RD
Mr. & Mrs. Richard Bissett,1,1,,2,
Mr. Andrew Waldron Wakefield,1,,,1,
Mr. Darren Bissett,1,,,1,
Mr. & Mrs. Russel Sheehan,1,,1,2,
"Christine, David, Eli, Julia Oliver",2,1,1,4,
derose85@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}