use strict;
my $str = 'Mrs. Doll Sheehan,,1,,1,
Ms. Sandy Frye,,1,1,2,
Mr. Thorne\'s,,,,0,RD
Mr. & Mrs. Richard Bissett,1,1,,2,
Mr. Andrew Waldron Wakefield,1,,,1,
Mr. Darren Bissett,1,,,1,
Mr. & Mrs. Russel Sheehan,1,,1,2,
"Christine, David, Eli, Julia Oliver",2,1,1,4,
derose85@gmail.com';
my $regex = qr/\b[A-Za-z']+\b(?=\s) \b[A-Za-z']+\b(?=,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}