re = /\b[A-Za-z']+\b(?=\s) \b[A-Za-z']+\b(?=,)/m
str = 'Mrs. Doll Sheehan,,1,,1,
Ms. Sandy Frye,,1,1,2,
Mr. Thorne\'s,,,,0,RD
Mr. & Mrs. Richard Bissett,1,1,,2,
Mr. Andrew Waldron Wakefield,1,,,1,
Mr. Darren Bissett,1,,,1,
Mr. & Mrs. Russel Sheehan,1,,1,2,
"Christine, David, Eli, Julia Oliver",2,1,1,4,
derose85@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end