using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\$|\$_|\.(?:find|prependTo|closest))\(\'|(?<!^)\G)\s?([.#][-\w]+)?[^()\s.#]*(?=[^()]*\))";
string input = @"/** Get ID */
$('#aaa').show();
/** Get class */
$('.bbb').hide();
/** Get IDs and classes and ignore other symbols */
$('#ccc.ddd > .eee').empty();
/** Ignore other string but catch IDs and Classes*/
$('div #fff.ggg .hhh').addClass('iii jjj kkk');
/** Test multiple seletor in the same line */
$('#lll.mmm').$('#nnn.hhh');
/** Weird selector */
$('#yo-lo-how_are_you');
/** Final test */
$('#test').removeClass('caris avane aoi').addClass('shirone teameow');";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}