import Foundation
let pattern = ##"(?:(?:\$|\$_|\.(?:find|prependTo|closest))\(\'|(?<!^)\G)\s?([.#][-\w]+)?[^()\s.#]*(?=[^()]*\))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/** Get ID */
$('#aaa').show();
/** Get class */
$('.bbb').hide();
/** Get IDs and classes and ignore other symbols */
$('#ccc.ddd > .eee').empty();
/** Ignore other string but catch IDs and Classes*/
$('div #fff.ggg .hhh').addClass('iii jjj kkk');
/** Test multiple seletor in the same line */
$('#lll.mmm').$('#nnn.hhh');
/** Weird selector */
$('#yo-lo-how_are_you');
/** Final test */
$('#test').removeClass('caris avane aoi').addClass('shirone teameow');
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)