const regex = /(?:(?:\$|\$_|\.(?:find|prependTo|closest))\(\'|(?<!^)\G)\s?([.#][-\w]+)?[^()\s.#]*(?=[^()]*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\$|\\$_|\\.(?:find|prependTo|closest))\\(\\\'|(?<!^)\\G)\\s?([.#][-\\w]+)?[^()\\s.#]*(?=[^()]*\\))', 'gm')
const str = `/** Get ID */
\$('#aaa').show();
/** Get class */
\$('.bbb').hide();
/** Get IDs and classes and ignore other symbols */
\$('#ccc.ddd > .eee').empty();
/** Ignore other string but catch IDs and Classes*/
\$('div #fff.ggg .hhh').addClass('iii jjj kkk');
/** Test multiple seletor in the same line */
\$('#lll.mmm').\$('#nnn.hhh');
/** Weird selector */
\$('#yo-lo-how_are_you');
/** Final test */
\$('#test').removeClass('caris avane aoi').addClass('shirone teameow');`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}