$re = '/(?:(?:\$|\$_|\.(?:find|prependTo|closest))\(\'|(?<!^)\G)\s?([.#][-\w]+)?[^()\s.#]*(?=[^()]*\))/m';
$str = '/** Get ID */
$(\'#aaa\').show();
/** Get class */
$(\'.bbb\').hide();
/** Get IDs and classes and ignore other symbols */
$(\'#ccc.ddd > .eee\').empty();
/** Ignore other string but catch IDs and Classes*/
$(\'div #fff.ggg .hhh\').addClass(\'iii jjj kkk\');
/** Test multiple seletor in the same line */
$(\'#lll.mmm\').$(\'#nnn.hhh\');
/** Weird selector */
$(\'#yo-lo-how_are_you\');
/** Final test */
$(\'#test\').removeClass(\'caris avane aoi\').addClass(\'shirone teameow\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);