package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\b[\s]?|[^x])([\d]{1}[\d]{2})(?:[^pi]|[\s]?\b)`)
var str = `This is (321) an example.
(321) also
including (321) //basically not possible, but can't hurt.
this (321) has another group with a p: 122p
this (321) has another group with a I: 123i
this x235 should be ignored cause (123) is what i want to match.
(123) is what i want, not x111 or 125p or 999i
in this 111 case there is no solution 555
101 202.something
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}