const regex = /(?:\b[\s]?|[^x])([\d]{1}[\d]{2})(?:[^pi]|[\s]?\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b[\\s]?|[^x])([\\d]{1}[\\d]{2})(?:[^pi]|[\\s]?\\b)', 'g')
const str = `This is (321) an example.
(321) also
including (321) //basically not possible, but can't hurt.
this (321) has another group with a p: 122p
this (321) has another group with a I: 123i
this x235 should be ignored cause (123) is what i want to match.
(123) is what i want, not x111 or 125p or 999i
in this 111 case there is no solution 555
101 202.something
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}