# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\b[\s]?|[^x])([\d]{1}[\d]{2})(?:[^pi]|[\s]?\b)"
test_str = ("This is (321) an example.\n"
"(321) also\n"
"including (321) //basically not possible, but can't hurt.\n"
"this (321) has another group with a p: 122p\n"
"this (321) has another group with a I: 123i\n"
"this x235 should be ignored cause (123) is what i want to match.\n"
"(123) is what i want, not x111 or 125p or 999i\n"
"in this 111 case there is no solution 555\n"
"101 202.something\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.