import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b[\\s]?|[^x])([\\d]{1}[\\d]{2})(?:[^pi]|[\\s]?\\b)";
final String string = "This is (321) an example.\n"
+ "(321) also\n"
+ "including (321) //basically not possible, but can't hurt.\n"
+ "this (321) has another group with a p: 122p\n"
+ "this (321) has another group with a I: 123i\n"
+ "this x235 should be ignored cause (123) is what i want to match.\n"
+ "(123) is what i want, not x111 or 125p or 999i\n"
+ "in this 111 case there is no solution 555\n"
+ "101 202.something\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}