#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(t=|start=)(?:\d+)"
Local $sString = "http://youtu.be/xxxxxxxx?t=30s" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=xxxxxxxx&start=30"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)