$re = '/(t=|start=)(?:\d+)/';
$str = 'http://youtu.be/xxxxxxxx?t=30s
https://www.youtube.com/watch?v=xxxxxxxx&start=30';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;