re = /(t=|start=)(?:\d+)/
str = 'http://youtu.be/xxxxxxxx?t=30s
https://www.youtube.com/watch?v=xxxxxxxx&start=30'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result