import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(t=|start=)(?:\\d+)";
final String string = "http://youtu.be/xxxxxxxx?t=30s\n\n"
+ "https://www.youtube.com/watch?v=xxxxxxxx&start=30";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}