using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(t=|start=)(?:\d+)";
string substitution = @"";
string input = @"http://youtu.be/xxxxxxxx?t=30s
https://www.youtube.com/watch?v=xxxxxxxx&start=30";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}