const regex = /(t=|start=)(?:\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(t=|start=)(?:\\d+)', 'g')
const str = `http://youtu.be/xxxxxxxx?t=30s
https://www.youtube.com/watch?v=xxxxxxxx&start=30`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);