#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*)(?>Bangalore)(.+)(?=29th March 1980 - 21 Dec 2014)"
Local $sString = "Kathick Kumar, Bangalore who was a great person and lived from 29th March 1980 - 21 Dec 2014."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")