import Foundation
let pattern = #"(.*)(?>Bangalore)(.+)(?=29th March 1980 - 21 Dec 2014)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Kathick Kumar, Bangalore who was a great person and lived from 29th March 1980 - 21 Dec 2014."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}