use strict;
my $str = 'Kathick Kumar, Bangalore who was a great person and lived from 29th March 1980 - 21 Dec 2014.';
my $regex = qr/(.*)(?>Bangalore)(.+)(?=29th March 1980 - 21 Dec 2014)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}