using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(?>Bangalore)(.+)(?=29th March 1980 - 21 Dec 2014)";
string input = @"Kathick Kumar, Bangalore who was a great person and lived from 29th March 1980 - 21 Dec 2014.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}