re = /(.*)(?>Bangalore)(.+)(?=29th March 1980 - 21 Dec 2014)/
str = 'Kathick Kumar, Bangalore who was a great person and lived from 29th March 1980 - 21 Dec 2014.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end