$re = '/(.*)(?>Bangalore)(.+)(?=29th March 1980 - 21 Dec 2014)/';
$str = 'Kathick Kumar, Bangalore who was a great person and lived from 29th March 1980 - 21 Dec 2014.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);