using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+\s+|^)(\S+\s+|)here is(\s+\S+|)(\s+\S+|$)";
string substitution = @"";
string input = @"Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}