use strict;
my $str = 'Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible';
my $regex = qr/(\S+\s+|^)(\S+\s+|)here is(\s+\S+|)(\s+\S+|$)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";