import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+\\s+|^)(\\S+\\s+|)here is(\\s+\\S+|)(\\s+\\S+|$)";
final String string = "Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}