$re = '/(\S+\s+|^)(\S+\s+|)here is(\s+\S+|)(\s+\S+|$)/';
$str = 'Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;