import re
regex = re.compile(r"(\S+\s+|^)(\S+\s+|)here is(\s+\S+|)(\s+\S+|$)")
test_str = "Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)