re = /(\S+\s+|^)(\S+\s+|)here is(\s+\S+|)(\s+\S+|$)/
str = 'Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result