#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^"]*(?:"[^"]+"[^"]*)+[^"]*)(["])?"
Local $sString = "title:"no spacing before" and text breaks title:"no spacing before" and text breaks " after this"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)