$re = '/([^"]*(?:"[^"]+"[^"]*)+[^"]*)(["])?/m';
$str = 'title:"no spacing before" and text breaks title:"no spacing before" and text breaks " after this';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;