const regex = new RegExp('([^"]*(?:"[^"]+"[^"]*)+[^"]*)(["])?', 'gm')
const str = `title:"no spacing before" and text breaks title:"no spacing before" and text breaks " after this`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);