use strict;
my $str = 'title:"no spacing before" and text breaks title:"no spacing before" and text breaks " after this';
my $regex = qr/([^"]*(?:"[^"]+"[^"]*)+[^"]*)(["])?/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";