package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^"]*(?:"[^"]+"[^"]*)+[^"]*)(["])?`)
var str = `title:"no spacing before" and text breaks title:"no spacing before" and text breaks " after this`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}