#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) \$adminvalues\s*=\s*" & @CRLF & _
" "" & @CRLF & _
" \( " & @CRLF & _
" [^,]+,\s*" & @CRLF & _
" '[^']+',\s*" & @CRLF & _
" MD5\('[^']+'\),\s*" & @CRLF & _
" '[^']+',\s*" & @CRLF & _
" '[^']+',\s*" & @CRLF & _
" \d,\s*" & @CRLF & _
" \d,\s*" & @CRLF & _
" \d\s*" & @CRLF & _
" \)" & @CRLF & _
" ";"
Local $sString = "$adminvalues = "(NULL, 'Admin12345', MD5('Admin12345'), 'Admin12345', 'Admin12345', 5, 0, 0)";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")