import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \\$adminvalues\\s*=\\s*\n"
+ " \"\n"
+ " \\( \n"
+ " [^,]+,\\s*\n"
+ " '[^']+',\\s*\n"
+ " MD5\\('[^']+'\\),\\s*\n"
+ " '[^']+',\\s*\n"
+ " '[^']+',\\s*\n"
+ " \\d,\\s*\n"
+ " \\d,\\s*\n"
+ " \\d\\s*\n"
+ " \\)\n"
+ " \";";
final String string = "$adminvalues = \"(NULL, 'Admin12345', MD5('Admin12345'), 'Admin12345', 'Admin12345', 5, 0, 0)\";";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}