const regex = / \$adminvalues\s*=\s*
"
\(
[^,]+,\s*
'[^']+',\s*
MD5\('[^']+'\),\s*
'[^']+',\s*
'[^']+',\s*
\d,\s*
\d,\s*
\d\s*
\)
";/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' \\$adminvalues\\s*=\\s*
"
\\(
[^,]+,\\s*
\'[^\']+\',\\s*
MD5\\(\'[^\']+\'\\),\\s*
\'[^\']+\',\\s*
\'[^\']+\',\\s*
\\d,\\s*
\\d,\\s*
\\d\\s*
\\)
";', '')
const str = `\$adminvalues = "(NULL, 'Admin12345', MD5('Admin12345'), 'Admin12345', 'Admin12345', 5, 0, 0)";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}