using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" \$adminvalues\s*=\s*
""
\(
[^,]+,\s*
'[^']+',\s*
MD5\('[^']+'\),\s*
'[^']+',\s*
'[^']+',\s*
\d,\s*
\d,\s*
\d\s*
\)
"";";
string input = @"$adminvalues = ""(NULL, 'Admin12345', MD5('Admin12345'), 'Admin12345', 'Admin12345', 5, 0, 0)"";";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}