using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script>((?!</script).)*?site(?1)*</script>";
string input = @"<script>
o.com
bla bla bla
</script><p>this is line></p>
<script>
google.com/jquery.js !
</script>
<script>
site.com
bla bla bla
</script><p>aa</p>
CONTENT
STYLE
SIDEBAR
...
<script>
site.com
aaa bla bla bla
</script><p>a</p>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}