import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script>((?!</script).)*?site(?1)*</script>";
final String string = "<script>\n"
+ "o.com\n"
+ "bla bla bla\n"
+ "</script><p>this is line></p>\n\n"
+ "<script>\n"
+ "google.com/jquery.js !\n"
+ "</script>\n\n"
+ "<script>\n"
+ "site.com\n"
+ "bla bla bla\n"
+ "</script><p>aa</p>\n\n"
+ "CONTENT\n"
+ "STYLE\n"
+ "SIDEBAR\n"
+ "...\n\n"
+ "<script>\n"
+ "site.com\n"
+ "aaa bla bla bla\n"
+ "</script><p>a</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}