import Foundation
let pattern = #"<script>((?!</script).)*?site(?1)*</script>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<script>
o.com
bla bla bla
</script><p>this is line></p>
<script>
google.com/jquery.js !
</script>
<script>
site.com
bla bla bla
</script><p>aa</p>
CONTENT
STYLE
SIDEBAR
...
<script>
site.com
aaa bla bla bla
</script><p>a</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)