re = /<script>((?!<\/script).)*?site(?1)*<\/script>/i
str = '<script>
o.com
bla bla bla
</script><p>this is line></p>
<script>
google.com/jquery.js !
</script>
<script>
site.com
bla bla bla
</script><p>aa</p>
CONTENT
STYLE
SIDEBAR
...
<script>
site.com
aaa bla bla bla
</script><p>a</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end