$re = '~<script>((?!</script).)*?site(?1)*</script>~si';
$str = '<script>
o.com
bla bla bla
</script><p>this is line></p>
<script>
google.com/jquery.js !
</script>
<script>
site.com
bla bla bla
</script><p>aa</p>
CONTENT
STYLE
SIDEBAR
...
<script>
site.com
aaa bla bla bla
</script><p>a</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);