# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<script>((?!</script).)*?site(?1)*</script>"
test_str = ("<script>\n"
"o.com\n"
"bla bla bla\n"
"</script><p>this is line></p>\n\n"
"<script>\n"
"google.com/jquery.js !\n"
"</script>\n\n"
"<script>\n"
"site.com\n"
"bla bla bla\n"
"</script><p>aa</p>\n\n"
"CONTENT\n"
"STYLE\n"
"SIDEBAR\n"
"...\n\n"
"<script>\n"
"site.com\n"
"aaa bla bla bla\n"
"</script><p>a</p>")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.